Services menu in Opsgenie is not responding

Incident Report for Opsgenie

Resolved

Our engineers have been closely monitoring the platform and are declaring this incident resolved. Thank you for your patience.
Posted Jan 14, 2025 - 16:47 UTC

Identified

Our team has identified the issue with the Services page in Opsgenie and is working to fix it.
Posted Jan 14, 2025 - 15:55 UTC

Investigating

Our engineering team is actively investigating this incident and working to bring the Opsgenie service back up as quickly as possible.

Users affected by this incident may notice that Services functionality is slow or completely unavailable for the web page

We will update this page as we have additional information.
Posted Jan 14, 2025 - 15:48 UTC