Issue affecting user invites and deletes
Incident Report for Opsgenie
Resolved
Between 3:30UTC to 13:05 UTC, a small number of user experienced some issues with user invites and user deletes . The issue has been resolved and the service is operating normally.
Posted 10 days ago. Sep 11, 2019 - 13:20 UTC
Investigating
We are investigating an issue with user invites that is impacting a small number of Cloud customers. We will provide more details within the next hour.
Posted 10 days ago. Sep 11, 2019 - 12:59 UTC